GeoModeller runs on most modern x86_64 PCs or workstations. 32-bit platforms are no longer supported.


CPU


Supports AVX instruction set:

  • Intel Sandy Bridge (introduced Jan 2011) or newer;
  • AMD Bulldozer (introduced Late 2011) or newer, recommend Ryzen 5 or Ryzen 7;

To use the embedded Intel HD graphics, Intel Broadwell CPUs (introduced Jun 2015) or later is a must.


Memory


8GiB minimum, recommend 16GiB or more, depends on the scale of user's data sets.


HDD


This depends mainly on the size of user's data sets. GeoModeller itself requires at least 2GiB disk space.


Graphics Card


nVidia does not support OpenGL over Microsoft Remote Desktop protocol on its GeForce product line.
To run our products on a remote computer using RDP, use nVidia Quadro series or AMD products.

All graphics cards supporting OpenGL 4.3 and above, with the latest driver from the vendor, are supported.

Including:

AMD Radeon HD 57xx or newer, introduced in late 2009;

nVidia GeForce 400 series, Quadro M, P, V series or newer, except GeForce 405;

Intel HD Graphics 7th Gen or above, seen on Intel i3, i5, i7-5xxx, 6xxx, 7xxx CPUs.


Operating System and Other Software

64-bit Microsoft Windows 7, Windows 10, preferably Professional or Ultimate. GeoModeller may run on Windows 8 / 8.1 but not officially supported due to the lack of support from the OS vendor (Microsoft).

GeoModeller currently supports Windows platforms.  We have the Linux version running in-house. Please contact us for available versions.


Adobe Acrobat Reader DC for documentation viewing, and it needs to be the system default PDF reader.